Incorporating conversation system resulted to ALSA lib error

anyone knows how to fix this error? i have been trying to figure it out since 5 days ago. I am incorporating to do a conversation system with the Picar-x bot, which i installed a microphone into. when i run my code sudo python3, it shows that ‘no module as speech-recognition’ even though i have installed it. when i run python3, this weird long error that keeps on going showed up. ALSA lib confmisc.c:1281:(snd_func_refer) Unable to find definition ‘cards.bcm2835_h [front.o: CARD=0’
ALSA lib conf.c:4745: (snd_config_evaluate) function snd_func_refer returned error: e or directory
ALSA lib conf.c:5233: (snd
config_ expand) Evaluate error: No such file or directory
ALSA lib pm.c: 2660: (snd_pem_open_noupdate) Unknown PCM front
ALSA lib pem.c:2660: (snd_pcm_open_noupdate) Unknown PCM
ALSA lib pm.c: 2660: (snd_pcm_open_noupdate) Unknown PCM cards. pem.center_lfe

Anyone knows how to fix this?

i also did nano asound.conf. which i changed the card to the device. it didnt work

It is recommended that you use the Raspberry Pi Terminal command line and use the commands to run the Python scripts.

  1. What about the error that occurs when you run the example. If you wrote the program yourself, please send us the program file, so that we can analyze and solve the problem.

  2. Please send us a screenshot of the steps you took to run the example, so that we can reproduce it and solve the problem.

how can i send the program to you privately? also, i ran the file in the terminal itself. by “cd picar-x/example” next “python3”

You can send the code package to this email address( and I’ll forward it to a technician to reproduce and test the issue.