Picar-X Robot Kit, Issues with Installing i2s amplifier

Hello, I am following the youtube tutorial for the Picar X, https://youtu.be/i5FpY3FAcyA?si=8mga7gH2_btzan8U.

At the 8:05 time, when running sudo bash i2samp.sh I get the error:

The i2s amplifier installer
does not work on this version of Raspbian.
Check GitHub: Let’s build from here · GitHub
for additional information and support

My version of Raspbian my Raspberry Pi 4B model is Raspbian GNU/ Linux 12. Do you have any advice on how this issue can be solved? Would downloading an older version of Raspbian fix the problem? I am new to using Raspberry Pi and I ran sudo apt upgrade -y so I think my pi is most up to date on the newest version of Raspbian.

Are you currently using a bookworm version of the Raspberry Pi system?
If so, i2samp.sh is not compatible with the bookworm version of the Raspberry Pi system, so picar-x will not sound.
If you install an older version (legacy), it is possible to solve the problem, and picar-x can get normal sound. (As shown in the picture)