Pico-4WD motors do not seem to be working properly

My son received a Pico-4WD Car kit for Christmas. He has been working on the setting up the car since then. Following the directions included he started to put on the sensor modules and motors along with the PICO board. We were able to connect the car to a Windows laptop and able to access the files on the PICO. The web link directed us to Raspberry PI page for downloading the files. Under the micropython section we were not able to find any file listed as pico_micropython_xxxx.uf2, instead we could only find rp2-pico-20220117-v1.18.uf2. So we moved this file to the PICO drive and let the car reboot. We were able to install the Thonny IDE. It did recognize the car and we were able to save files and run programs on it.
The problem is the motors do not seem to be working properly. When the board receives power (either from the batteries or the microusb connection) one of the motors starts running continuously. We tried to run the test program with everything commected out except test_motor(). Thonny displays front, back, left, right, stop. The continuously running motor continues to run and the other motors do not move.

First, you can find the UF2 file for MicroPython here:

Secondly, we need your help to take a video to show the state of the car after running the code.

Thank you so much for your great cooperation.

I had previously loaded a uf2 file, but for troubleshooting purposes, I followed the link and loaded the uf2 file from the site to the car. It did not correct the issue with the motor continuously running. I have uploaded a video for your support group to review.

I have watched your video, and confirm that it has nothing to do with the uf2 file, it’s your pico that is connected backward, causing the motor to be abnormal.

Please install it like this:

It works now, thank you for your help!