Pironman 5 HDMI failure

Hi, I finally got my Pironman 5, I’m so happy!

But just now I powered on the Pironman with just an nvme, and no sdcard. I got a screen saying I could decide to install something for a second. Then the display went blank, and since I already had an OS on the sdcard, I powered down and inserted my Raspberry Pi 5 sdcard with Raspberry Pi OS (Debian 12).

Now I get no screen no matter what I try, not on HDMI 0 nor on HDMI 1, but it does boot from the sdcard and I can get to a shell over ssh. I installed the software from pironman.git (branch v2.0) and now the other stuff just works - fans, small display… just no HDMI!

Any tips on what I can do to try and get HDMI to work again? I hope I don’t have to disassemble everything just to try the onboard micro-hdmi.

Thanks. :smiley: Mark

Decided to disassemble and the direct connection with the Pi does give me HDMI. But when I assemble back the hdmi adapter … just no display at all. I think my HDMI adapter is dead. Everything works, the nvme, the tiny display… but no HDMI.

I don’t know if anyone will believe me, but I thought this part (the HDMI adapter) smelled funny (burned) when I took it from the anti static plastic wrapping. Just this part, the others are ok.

This is the 2nd batch of Pironman 5, I was one of the people who immediately pre-ordered when the first batch got sold out. Received it today, assembled it and then this happened.

Uploading a video so I can show you just what’s going on.

Here’s the video:

I think the RGB LEDs of the IO hat are also not working. I uploaded another video to demonstrate.

For RGB lights, have you install pironman software as mentioned on this instructions? Set Up Pironman5 on Raspberry Pi/Ubuntu/Kali OS — SunFounder Pironman documentation and check for RGB jumper as shown on pic.

For HDMI output, the issue seems to be an hardware problem with USB HDMI Adapter, for that you need to contact consumer service at service@sunfounder.com

Thanks @Weirdguy. I checked: jumpers on or not on the board, doesn’t make a difference: no activity in the RGBs.

I did edit the eeprom but I don’t think it affects the LEDs. However, when I turn the Pironman off, the green LED stays on and green. Is it supposed to do that?


# sudo pironman -c
config file:/opt/pironman/config.txt

temp_unit = C
fan_temp = 50
screen_always_on = False
screen_off_time = 60
rgb_enable = True
rgb_style = breath
rgb_color = 0a1aff
rgb_blink_speed = 50
rgb_pwm_freq = 1000
rgb_pin = 10
pironman ~ # systemctl status pironman.service
● pironman.service - pironman service
     Loaded: loaded (/lib/systemd/system/pironman.service; enabled; preset: enabled)
     Active: active (running) since Sun 2024-06-30 13:27:40 CEST; 5min ago

I can change the rgb_style to static or whatever: no change. Just no leds. I tried different pin numbers just to be sure.

I mailed sunfounder service, we’ll get it sorted I’m sure. They’re really helpful on the forums.

I see you didn’t install the good software for the case. Normaly for pironman 5, you need to enter this command : sudo pironman5 -c. So you need to remove pironman with those commands : sudo pip3 uninstall pironman
sudo rm -rf pironman
and install pironman5 with this tutorial: Pironman 5 - NVMe M.2 SSD PCIe Mini PC Case for Raspberry Pi 5 — SunFounder Pironman documentation
cd ~
git clone https://github.com/sunfounder/pironman5.git
cd ~/pironman5
sudo python3 install.py

When you turn off the rpi5, those LEDs stay on, it’s normal.

Normaly it should work, fell free to give me feedbacks.

Ohh did I really install the wrong software? :man_facepalming: good catch.

So, to uninstall, I tried both pip3 uninstall pironman and /usr/local/bin/pip uninstall pironman but I’m getting this:

# sudo /usr/local/bin/pip uninstall pironman
error: externally-managed-environment

× This environment is externally managed
╰─> To install Python packages system-wide, try apt install
    python3-xyz, where xyz is the package you are trying to

    If you wish to install a non-Debian-packaged Python package,
    create a virtual environment using python3 -m venv path/to/venv.
    Then use path/to/venv/bin/python and path/to/venv/bin/pip. Make
    sure you have python3-full installed.

    For more information visit http://rptl.io/venv

note: If you believe this is a mistake, please contact your Python installation or OS distribution provider. You can override this, at the risk of breaking your Python installation or OS, by passing --break-system-packages.
hint: See PEP 668 for the detailed specification.

Should I use --break-system-packages? Sorry, I have never worked with Python much :slight_smile:

Pass this step, now try to install the pironman5 version. I think this will uninstall previous version.

1 Like

I saw in your previous videos that you have install nvme, be sure to follow tutorial step by step to configure it correctly. I means the good tutorial for Pironman5 :wink:


You’re right! Thanks… the LEDs are working now!

LOL yes indeed. But I will have to wait before I can use it: the NVME did work, but it uses the 5V pins from the HDMI adapter and unfortunately I just can’t get the output to work.

Good news :+1:t2:. For the HDMI you need to contact consumer service at service@sunfounder.com, it seems to be a defect part. For now enjoy your RGB led :grinning:

Right after my PEBKAC failure with the LEDs, I figured, what would I ask the customer to do first? Try a different HDMI cable.

So I tried a different HDMI cable. And guess what?

Yes. It works. (Even though the board still smells funny!) So that’s weird - the other cable works via micro-HDMI but not regular HDMI… wonky.

But I’m really happy that this is the issue apparently, and now I am going to re-assemble the Pironman 5!

If it works with different HDMI cable, I hope the board is ok even with a “funny smell”

After fully assembly, make sure to configure nvme as tutorial, enable it into boot\firmware\config, copy the OS from SD card to nvme and change boot order into Sudo rpi-eeprom-config --edit bootorder=416 and reboot.

1 Like

It’s working! NVMe too, so: problems solved. :man_dancing: :mirror_ball:

Thank you for the help, @Weirdyguy.

Can a moderator please mark this as [solved]? :cowboy_hat_face:

1 Like

Congratulations! :+1:t2: Have a good experience with your Pironman5 ! :grinning: I’m glad to help you.

Another good feature is the dashboard to monitor the pironman5 and customize it through a web browser IP:34001.

1 Like