RasPad 3 power issue

I bought a RasPad 3 in December. I assembled it with my own raspberry pi 4, fired it up and everything seemed to be fine. I let the batteries charge for several hours and when I unplugged the power supply the unit died. I tried charging again for several hours with the same result. I contacted support and they had me videotape the issue and take a voltage reading of the battery which was 8 plus VDC. They said they would get back to me after analyzing the problem and that was the last I ever heard of them. I have emailed them a couple times since and have had no response. Has anyone else had a similar issue with the battery? Also has anyone had a similar experience with support or the lack thereof?

We are very sorry for the trouble caused to your work. We promise to give you a satisfactory solution. If it is a hardware problem, we will arrange to send you new hardware.
But the prerequisite want to analyze where the problem is.

  1. So we need you to provide us with a video of the problem, so that we can analyze and solve the problem. So we need you to provide us the video of the problem, so that we can analyze the problem and help you to solve the problem at once.
  2. Please open the back cover of the raspad, connect the power adapter to charge, and provide us with the status of the motherboard’s indicator and charging indicator.
  3. And connect the power adapter, open the raspad, and then unplug the power, observe the raspad’s screen working status. (Provide video)
  4. Please also provide the raspad shipment date, we check which batch it is, so that we can better investigate the problem and give you a satisfactory reply and solution. (There is a date label inside the package or raspad)

I have already provided a video and photo of the testing that I have done to your support staff. Check with them for my previous correspondence. Here is a copy of the photo. Unable to upload the video.

The order # is 2755 and my contact was Torres in service.


Torres he said he had replied to you but you then sent the email again saying we hadn’t replied to you so he tried to reply to you again using three different email addresses, not sure if you got the email or not, maybe you could check your spam email to see if the email is being assigned to a spam email address.

I checked my spam folder and I have nothing in there from Torres. I have no messages regarding any solution to my problem after I sent him a video and photo for his request. If he has a proposed solution then please send it through the forum as I am no longer getting any emails from him for some reason. Nothing has changed with my email on this end.


I just received the emails sent by Torres and cs yesterday. I don’t know why they showed up late but I did receive them, and I have responded to Torres offer to solve the issue. Thank you.


1 Like