Raspad 1 Startup

Hi Everyone:
I dug my Raspad 1 out of moth balls since I have a project for it. The battery seems to charge just fine, but I cannot seem to get it to start. Since I can’t find my manuals, I was not sure how to reset my Raspad 1. I held the power button down thinking that would do it, but no luck. Also tried using the reset button during attempted startup to see if that made any difference, but once again, no luck. I know this is an old product, but I thought someone on the forum could help. Can someone please help me with startup since I am stuck?

Suggest you record the operation steps video to us, easy for us to analyze and solve the problem. (Remove the back cover and observe the working status of the indicator light)
Please make sure all the wiring is normal contact well yet.
Please make sure there is a burned system in the SD card.

That would be nice, but there isn’t anything to record. When I press the power button, nothing happens. The RPi does not power up and none of the LEDs turn on. After charging the battery, all three of the charging LEDs are lit. I also open the back of the RasPad and did not see anything out of the ordinary. All of the cables seem to connected as expected. I cannot see anything that looked burned on the pcb. Checked the batteries at their terminals, 4.1 volts. Anything else you can think of to check?

We suggest you provide us with a video of the operation process, so that we can analyze and solve the problem. We need to confirm whether the battery is damaged or the motherboard has problems.
It is easier for us to send you the appropriate hardware to solve your problem.
If the video memory is too large, you can upload the video to your OneDrive and share the link to the video with us and give us access to it.

Here is the video, https://1drv.ms/v/s!ApFDqDHz1AQLj0R6VXLyypdKD9DX?e=fM4HcE. As mentioned, everything is plugged in and the RPi does not get any power. The batteries are showing about 4.2 V as is the connector at the board. Thanks for the help.

P.S.: I am a retired Electrical Engineer (35 year design experience) and should be able to find any obvious issues.

Sorry, if you replace the HDMI cable and the power cable and it still doesn’t work properly, the Raspad motherboard may be damaged. raspad1 has been discontinued and there is no corresponding version of the motherboard for you to replace. Because of the long time span, we recommend you to choose the latest version of RasPad 3.