The pisloth kit does not run

I tried to buy and use Pisloth.
Raspberry pi os (legacy) full and Raspberry pi os (legacy, 64-bit) have been used as the basis for writing this article.
And as shown in the document, we installed robot-hat (git clone GitHub - sunfounder/robot-hat: Robot Hat python library) and pisloth (git clone -b v2.0 GitHub - sunfounder/pisloth: PiSloth from SunFounder) ) and proceeded with .
Finally, I entered and the warning below appears, leaving a question.
Can you tell me which part is wrong?

— Warning —

The i2s amplifier installer
does not work on this version of Raspbian.
Check GitHub: Let’s build from here · GitHub
for additional information and support

The problem has been fixed.
Please update the code again:
cd ~/pisloth
git pull
sudo python3 install
Go back and install again:
cd ~/pisloth
sudo bash

Can you tell me why it didn’t work?
I wonder if I did something wrong or if the code was wrong.

Did you follow the steps in our reply to update the code and it still doesn’t solve the problem?
We suggest you reinstall your system and install our code again to see if the problem is solved.
If there is any problem, we suggest you can provide the problem picture or video, so that we can analyze and solve the problem.

It’s settled.
But I was wondering if it was my fault or if the code in github was wrong.

It was a problem with our code, so our engineers made a fix.

Thank you for your quick resolution.

1 Like