Unable to zero any of the servos on PiSloth

Hi. I’m assembling a PiSloth but have not been able to zero any of the servo motors.

I’m using a Raspberry Pi 4 with a brand new image of ‘buster’ Raspberry Pi OS. I’ve successfully installed all of the PiSloth software requirements per the documentation (I’ve also ensured that i2c is enabled) (and I’ve reimaged and tried reinstalling things multiple times).

I’m at the point where I’m zeroing the initial two servos but at no point am I seeing movement (I’ve rotated them manually slightly away from their default positions and have tried the servo_zeroing.py script and I’ve shutdown/started the Pi itself multiple times. They’ve never moved. I’ve tried zeroing all 4 servos in P11 and nothing. I’ve also plugged them all into P0-P3 and tried running some of the example scripts, but nothing moves.

Having watched a few videos other people have posted to the forum, I’ve noticed a couple of differences to what I’m seeing that might be relevant:

  1. I’m not hearing a chime during startup (just kind of a low hum type sound). However, the speaker seems okay, because if I run the dancing.py example, I hear the song playing.

  2. Is there supposed to be a green light lit up on the hat by the RST button? When I turn the system on, I see an orange light beside the USR button and shortly afterwards there’s a flashing white light around the center of the hat… but that’s it. Should I be seeing a green light?

Any suggestions?


  1. Is the robot hat connected to the battery for power supply?
  2. Please confirm whether you have correctly installed all the required source codes of the pisloth product. Is there any error reported during the installation process?
    If you have a multimeter at home, you can measure the PWM pin on the robot hat to measure the voltage of GND and 5V.
    Please provide a picture or video of the problem.

Hello, I had the same issue with my Picar X…
forget P11 it doesn’t work. you have to install software on your PI and use
a PC or mobile with ezblock, to do thecalibation , after this steps, the normal PWM output will work but not P11

dont forget to flash your pi with advanced wifi parameters and also the sound on…
it will play melody after successful start.

1、First of all, are you using python control or ezblock app control?
python control needs to install the Raspberry Pi system, download the required libraries on the Raspberry Pi system terminal, confirm the installation process with or without error reporting at
2、Servo adjustment?
Please follow our tutorial to operate:
If you operate as required, but still cannot achieve servo adjustment, please provide a screenshot of the execution code and a video of the robot servo state after code execution.
3、Is the robot hat connected to battery power?
4、If you have a multimeter at home, you can measure the PWM pin on the robot hat, and measure the voltage of GND and 5V.
Please provide pictures or videos of the problem.

Please provide pictures or videos to us so that we can help you solve the problem faster and more accurately.

Including your picar-x product, the way to check is the same as the PiSloth product.