Error when trying to run script

I received an error that said “this hardware is not supported” when I attempted to run the script as I was getting my raspberry pi setup for the Sunfound Picrawler Kit. Is something wrong with the robohat or is there a recommended way to redo the installation?


What system are you using and what version is it ?
We suggest you try
Debian bullseye
Debian buster
to see if it works.

I was using Raspberry Pi OS Lite (Legacy) which is a port of Debian Buster. I just tried using the Raspberry Pi OS lite (Bullseye) and the same error message has popped up.

Any other recommendations?

Did you reboot the system after executing the script and then go back to the sound example and did the bot make any sound.
Please provide us the full screenshot. It will be easier to analyze and solve the problem.

I’ll be able to provide a full screenshot later but now the problem seems to be that the RobotHAT is not turning on despite the batteries being fully charged

Okay, we’re waiting for your screenshot.

Is this what you needed for a “full screenshot”?

We have fixed the issue and the code has been re-uploaded.
You just need to pull the code.
Execute the command as follows:
cd picrawler/
git pull
sudo python3 install
After re-pulling the code and installing it, reboot the Raspberry Pi and go ahead and execute install again:
cd picrawler/
sudo bash
After the installation, reboot the Raspberry Pi again and go back to executing the sound example.


I was able to successfully run the script. However I am still rerunning it because I still cannot hear any sound. Is there a certain number of times before the speakers will begin to work or is something else wrong?

If you installed as requested and restarted your Raspberry Pi system, and then went to run the sound example it did not sound.
It is possible that your Raspberry Pi is connected to an external screen, which is causing an audio conflict.
So please run sudo killall pulseaudio and then run the sound example again to see if it works.