PiCrawler Raspberry Pi 3b - No Sound

I fully assembled the PiCrawler and everything works great except there is no sound!
Reinstalled the below module multiple times as instructed to with no luck.
cd /home/pi/picrawler
sudo bash i2samp.sh

I’d appreciate any help to find a solution to correct the problem.

  1. You are currently using a Raspberry Pi 3, right? What version of the Raspberry Pi system are you installing?
  2. Your installation of i2samp.sh is not successful?
    Please send us a screenshot of your installation so that we can analyze the problem.
    If you install i2samp.sh successfully, start the Raspberry Pi, and then execute the sound example, but still can not sound, please execute sudo killall pulseaudio command, and then execute the sound example to see how it works.
  3. We also suggest you to send us the video of executing sound example which can’t make sound, so that we can analyze and solve the problem.
  1. I am using a Raspberry Pi 3 Model B Plus Rev 1.3. I installed Raspbian GNU/Linux 10 (buster)
  2. It seems that the install of i2samp.sh was successful, please see screenshots (attached)

    i2samp install 2
    i2samp install 3
  3. Still no sound from the picrawler! Screenshot of sound_effect.py is attached.
  1. From the screenshot you provided, i2samp.sh is installed successfully.
  2. You execute the sound_effect.py code and press q: to play the background music, but it fails to make sound:
    We recommend that you send us a video of the execution sound example that fails to make sound so that we can analyze and resolve the issue.
  3. Or you can prepare another kind of SD card for installing ezblock OS image, control it with ezblock studio APP, and run the example with sound effect in the APP to see if robot hat speaker can make sound.
    Play with Ezblock — SunFounder PiCrawler Kit documentation

Ok, I installed EZBlock system. All works except the speaker! I still do not get any sound from the robot-hat speaker!

You use ezblock studioAPP to connect to Spider Pie, and then go to run the sound example, we suggest you provide us with a video.
The video of the connection process, with the process of running the example is provided to us.
If the sound is not working, we will arrange to send you a new robot hat.

As requested…video can be downloaded from the following link.

Requested video can be downloaded from the following link.

https://drive.google.com/file/d/195FO3N6McUni8ZKnH5I-OoXYfOsD-ex4/view?usp=drive_link

Ron Kowch

When you run the sound effect example, open the print window to see if any errors are reported. (as shown)

If there is no error message, the robot hat’s speakers are damaged. We will arrange to send you a new robot hat.
If there is an error message in the print window, it may be a software code problem, please provide a screenshot of the error message to us, so that we can analyze and solve the problem.

I ran the ‘dance’ example with the print window open. No errors were reported. see below

It should be a damaged speaker., we will have an after-sales person contact you later to send you a new robot hat.

I received the new Robot-Hat. I installed it and the PiCrawler still does not play sound. I noticed when I took off the old Robot-Hat that the speaker was crushed (damaged) compared to the new one. I removed the new one and noticed that the new speaker was now crushed as well. I then noticed that had installed a heat sink on my RaspberryPi processor…the heat sink pressed against the speaker and had damaged it. See the attached pictures. It may be a good idea to include a statement in the instructions to tell customers to remove any heat sinks that may have been installed to avoid damage to the Robot-Hat.

Would it be possible for me to purchase a replacement Robot-Hat?


Is there a way that I could purchase a replacement Robot-Hat?

Sorry, we missed the unexpected situation of installing the heat sink. From your picture, it looks like the diaphragm of the speaker is crushed, and it can’t vibrate, so it can’t produce sound. Please try to remove the heat sink, install robot_hat again, and run the music playback program to see if the diaphragm of the speaker can be recovered. Or you can try to use adhesive tape to stick the diaphragm, then pull up the tape to recover the dent.

BTW, here’s the link to buy it from Amazon Canada, it’s the new version of the robot hat and is compatible with the old one.
https://www.amazon.ca/dp/B0CKTD7QJB?ref=myi_title_dp

OK, I was able to repair one of the speakers. I now get sound when running the EZBlock system, but I do not get any sound when I run the Raspbian GNU/Linux 10 (buster) system. i2samp.sh does not produce any sound and there is no sound when I run sound_effect.py.

Any ideas?

  1. Note that sudo is required to run.
  2. Sometimes it is necessary to install the i2samp.h script several times for it to work.
  3. Manually check the sound card configuration: use “sudo aplay -l”, to see the list of sound cards, use “sudo cat /etc/asound.conf”, to see the configuration file of the sound card serial number consistent.

021801

  1. I did use sudo to run
  2. I did install the i2samp.h script many times…it still does not work
  3. I checked the sound card configuration. The sound card serial numbers are consistent. See screen shots below.

I still get no sound from the speaker.

1.What version of Raspberry Pi system are you currently using.
2.When you execute i2samp.sh installation, is there any error report, if so, please provide the error report screenshot to us.
3.Execute i2samp.sh to install:
cd ~/picrawler
sudo bash i2samp.sh
After successful installation, execute the sudo reboot command to reboot the Raspberry Pi.
Go ahead and run the sound example again to see how it works:
cd ~/picrawler/example
sudo python3 3.tts_example.py
If the speakers don’t sound, run the sudo killall pulseaudio command again and go run the sound example again to see how it works.