Exception: Bluetooth adapter not found (Pi Car-X)

I followed the instructions here:

The Pi boots and the hat speaker makes a sound, but I can’t connect via wifi or bluetooth. I tried laptop, tablet and phone. None worked.

EDIT: I can connect via SSH.

Please help me because this was a Christmas present and I need it to work.

this is the output if I run:

pi@picar:~ $ sudo ezblock-service

------------------------22/12/27 00:37:05------------------------
22/12/27 00:37:05,457 [Entry] python_version: 3.7.3
22/12/27 00:37:22,786 [Entry] ezblock-service start version: 1.2.1 
22/12/27 00:37:22,788 [websokcets] Ezb_Service.start_service
22/12/27 00:37:23,196 [reset_servo] Products type: null
22/12/27 00:37:23,247 [reset_servo] i2c_adress_list: ['0x14']
22/12/27 00:37:23,249 [websokcets] Ezb_Service.ezb_service_start
22/12/27 00:37:27,219 [websokcets] WS.user_service_start does not auto-run
22/12/27 00:37:27,235 [websokcets] [Process] __start_ws__: 657
22/12/27 00:37:27,252 [websokcets] WS.__start_ws__
22/12/27 00:37:27,437 [BLE] Not BLE only, changing config
Process worker 2:
Traceback (most recent call last):
  File "/usr/lib/python3.7/multiprocessing/process.py", line 297, in _bootstrap
  File "/usr/lib/python3.7/multiprocessing/process.py", line 99, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/local/lib/python3.7/dist-packages/ezblock-1.2.1-py3.7.egg/ezblock/websockets.py", line 705, in __start_ws__
    self.ble = BLE('ezb-Raspberry')
  File "/usr/local/lib/python3.7/dist-packages/ezblock-1.2.1-py3.7.egg/ezblock/ble.py", line 26, in __init__
    self.uart = BLE_UART(name)
  File "/usr/local/lib/python3.7/dist-packages/ezblock-1.2.1-py3.7.egg/ezblock/ble_uart/__init__.py", line 132, in __init__
  File "/usr/local/lib/python3.7/dist-packages/ezblock-1.2.1-py3.7.egg/ezblock/ble_uart/__init__.py", line 154, in init
    raise Exception("Bluetooth adapter not found")
Exception: Bluetooth adapter not found

What version of Raspberry Pi are you using? You need a Raspberry Pi with Bluetooth.

Thank you for your reply. I am using Pi 2B.

I purchased this kit: https://www.amazon.co.uk/gp/product/B08FB6P88L/ref=ox_sc_act_title_1?smid=A337BOQBCQBMQG&psc=1

it specifically says " Raspberry Pi 4B 3B+ 3B 2B" in the description, but Pi 2B doesn’t have bluetooth.

I took my Pi 3B out of my media player and put it into the robot. It all seems to work ok now.

This is all very confusing and misleading. I would suggest you remove 2B from the description so that other people don’t make the same mistake.


Thank you for your reminder, we will arrange for revision. :hugs: :hugs: