Lesson 25 in Raphael kit

i have the Raphael kit and in lesson 25 the DHT liberary is not working because it is discontinued .I have tried with Adafruits liberary that doesnt work at all. Do you know of a different liberary that can be used?
Thanks in advance
Rasmus Bartholdy
(from Denmark)

1.What type of Raspberry Pi board are you currently using and what version of the Raspberry Pi system are you using?
2. When you run the example, is there any error report, if so, please send us the screenshot of the error report, so that we can analyze and solve the problem.

i use pi 4 (400) and it should be 32 bit the computer says but i upgraded to 64 bit but it still says 32 bit.I have tried different liberarys but nothing works and it says that the dht11 is not supported. The system will not use Adafruits liberary because its another linux distro. Sunfounder should upgrade its hardware pieces more often.

Here’s the video tutorial:
https://docs.sunfounder.com/projects/raphael-kit/en/latest/python_video/video_25_dht11.html
Perform the test dht11 module. We went to run the test and it works fine.
If you encounter any problems, please provide us with screenshots of the problems, so that we can analyze and solve the problems.
You can also send us a screenshot of your operation process, or record a video to us, so that we can help you solve the problem.

i asked for a liberary that works?

the DHT11 liberary doesnt work anymore.

Are you talking about a problem with DHT11 or a problem with the code?
Please record a video or take a screenshot of the process of using DHT11, and tell us in detail what happens when you run the code, so that we can analyse and solve the problem.
We follow the video tutorial you provided to operate the verification, which are working normally. So there is no problem with the code.

as i have written several times i can not download the dht11 liberary it is not assesable here, It is not possible to get that leberary here in Europe. I dont know if you people are in USA or somewhere else.

Do you mean that dht11 cannot be installed successfully by executing the command sudo pip3 install dht11?
We suggest that you provide us with a screenshot of the installation error message so that we can analyse the problem.
Please also provide us with the Raspberry Pi system you are currently using, what version is it. Please let us know so that we can reproduce the problem.

i dont have time to wait 2-3 days for your support to return, and nobody has in modern life. Now i have waited at least 10 days and you have not provided anything constructive yet. I have told you several times that the problem is the DHT11 liberary/driver thats not part of the linux pi system. Still you want pictures even though i have told you what the problem is. I have worked with linux many years and you write to me like im a newbie to Linux.
I was thinking about getting a robot car from Sunfounder but i will not buy it from you because your support is so bad.

Whyshould an Arduino liberary work when i use a Raspberry4 (400) ?

tors. 18. jul. 2024 kl. 19.05 skrev David via Sunfounder Forum <notifications@sunfounder.discoursemail.com>: