PiCar-V servos and wheels not working

Hi, I’ve mostly assembled the PiCar-V kit. I am at the step where I attach the servos and run the python script to configure them. I have installed all of the dependencies per the instructions and can run the script that is supposed to make the servos turn. When I run the script, I get no errors and it appears to run fine, except that the servos on the car do not turn. I also tried running the python scripts to test the wheels. Again the scripts run with no errors and even say that the wheels are turning, but nothing on the car actually happens.

I assume there is some sort of connection issue, but I’m not really sure how to troubleshoot the problem. Any suggestions?


  1. Suggest that you will operate the steps, recorded video to us, easy to analyze the problem.
  2. Check whether the wiring is correct.
  3. Make sure the battery power is sufficient, and the battery pack is connected to robot hats.

Here are a couple videos of me trying to run the servos and rear wheels. Also a couple pics attached. Please let me know what else you may need. The raspberry pi is plugged in and the batteries are also charged and in the battery pack. The wires seems to be connected to the correct locations.


From your video, it looks like you have a problem with your battery pack.
The reason: your robot hat is not getting power from the battery, causing the program to run properly, but the module to not work.
Your external power supply is powering the raspberry pi, so it can be programmed to run code, but for the module to work, the robot hat has to be powered. The Raspberry Pi does not power the robot hat.
But your robot hat is hooked up to a battery pack, the robot hat is powered, and the battery will power the Raspberry Pi through the robot hat. So when you use the battery to power the robot hat, the Raspberry Pi does not need to be powered by an external power supply, the robot hat will power the Raspberry Pi.

  1. Is your battery connected to a battery. If so, please let us know the specifications of the battery you are using.
    Please refer to our tutorial for battery specifications:
    Components List — SunFounder PiCar-V documentation

  2. If your robot hat is connected to the battery, but the robot hat is not working, you can use a multimeter to measure the voltage of the battery.

  3. Please follow our tutorial steps to work.

Thanks. I unplugged the power adapter and am now running the raspberry pi and everything using the battery pack that came with the picar. Still having the same issue. The raspberry pi will run the code and the robot hat appears to be receiving power. But nothing happens. I will try a multimeter. What connections should I check? How do I check if the robot hat is receiving power and is working?

You can try to measure the voltage of the red and black pins on the PCA9685 board with a multimeter. Normal should be around 5V.