Picar X not connecting to wifi when using ezblock

I have much of the same issues that this guy has: “EZ Block Studio Not Connecting to WIFI”, except I have tried all the solutions in this thread without any success.

In the ezblock application I am able to connect to bluetooth, but when connecting to Wi-Fi I get the message “mobile devices and product are not on the same network, you can : 1. go to system settings and change the wi-fi on your mobile device. 2. click the button below to change the wi-fi of the product.” When I click on the button I verify that my Wi-Fi network name and password is correct, and is the same Wi-Fi network that my phone is connected to. When I hit verify, it still gives me a connection error and I can’t move beyond this screen.

I have connected the raspberry pi to a screen and keyboard. I verified that it is connected to the Wi-Fi network, and can ping google. This is the same Wi-Fi network that my devices have been connected to when trying to connect to the pi.

My username and password is the default “pi” and “raspberry”. SSH is enabled, with “use password authentication”. The wireless LAN SSID is set to my wifi network name with correct password.

I have tried to connect to the robots using an android phone, an iPad and a computer running windows. The phone and the iPad has the same problem, while on the computer it says “connection error”. I have tried deleting data on the bluetooth connection on both the ipad and the android, as well as reinstalling the app.

I have found a emergency solution in connecting the PC to the pi through a ethernet cable. This keeps me connected enough to the pi to send signals and download EZ-block programs. I would rather not have to keep the robot connected to the PC though, and I also still face issues with not being able to recieve camera footage (or any other form of data) from the robot even though it seems like the robot responds to the joystick commands from my PC. It’s as if the communication is only one-way.

I have 5 picar X instances and all of them have nearly the exact same problem, indicating that the issue is tied to either the operating system or the network, and not technical errors with equipment itself. I have been using the “Raspios-buster-armhf-lite-2021-1-11_EzBlockOS-v1.2.3” image when flashing the SD cards, but I am pretty sure there is a more recent version 1.2.4 that isn’t available on the website here EzblockStudio/download. I currently have some robots with 1.2.3 and one with 1.2.4. Both have the same problem. They are running on Raspberrypi 3 b+.

  1. Try connecting your mobile device to a different WiFi network, then try connecting to the work network again. Choose a WiFi network with a stronger signal.
    2.Turn off the WiFi on your mobile device and use mobile data instead. Then enable the mobile hotspot and try connecting the picar-x app to it.

Hey there!

We managed to fix it by going into the wifi settings on our computer and changing it from a public connection to a private one. Thanks for the help anyway and thank you very much for the fast response time, even though it took us a while to get back to you!

Please feel free to contact us to resolve any issues.