PiCarX EzBlock Disconnecting

Hello hoping someone can advise why my ezblock app will not stay connected to my Pi Car X.

My niece and I got the build completed and booted it up, installed the ezblock software I got from the website on my android, couldn’t find it in the google play store so had to download the apk straight from EzBlock Studio. Opened it and tried to connect for the first time and it finds the bluetooth device, connects and recognizes its a first time setup and starts the quick config, as soon as I enter the wifi name and password i get a message that the picar has disconnected.

I can see the pi on my home router and SSH into it fine.

Things I have tried.

Reformat SD Card - with and without Wi-Fi configured
New SD Card
New PI
Reset button
Different Wifi Router
Apple Ipad
Samsung Galaxy Tablet
Windows Chrome Browser
New Batteries
Mobile Hotspot

Here is an example video, let me know if you have any questions, we have our science fair on Tuesday 5/23 and I am not sure how to get this thing to stay connected… picar x wifi device disconnect - YouTube

Please check if ezblock OS is version 1.2.1 (as shown in the picture) at

Now the ezblock studio for android is online in Google Play Store, you can download and install the ezblock app again in the store and try to connect again.

ez block version is 1.2.1 but I will download the image again from the link and flash to SD card. Downloading latest android app from play store to see if it works but I don’t think it will since it did not work on Iphone or Chrome Web Browser either.

Any other suggestions are greatly appreciate I need to get this working today for Science Fair tomorrow. Will report back shortly.

I reinstalled the app from the play store and reimaged the SD card with the latest version 1.2.1 from the link you provided but it is still experiencing the same issue. What else can we try? we are desperate. Thank You!

Tried from an apple iphone again as well and same issue on the iphone.

Update: I was able to get the picarx to stay connected by using version 1.1.4. I can calibrate the wheels and pan and tilt angle but when I try to run any of the example programs I get error “cannot import name ‘PiCarX’ from ‘picarx’ (/opt/ezblock/picarx.py)”

What can I do to resolve this error? Please help

We have checked and tested the three ends of your feedback, and it is possible to connect successfully.
The latest version of ezblock studio for android is V3.2.143
The latest version of ezblock studio for iOS is V3.2.140
The latest version of ezblock studio for PC is V3.2.137
Also requires ezblock OS version V1.2.1:
We hope you can provide us with your ezblock OS image version information and ezblock studio version information to us.
Tip: It is recommended that you do not install any other software on the SD card where you installed Raspios-buster-armhf-lite-2021-1-11_EzBlockOS-v1.2.1.img.

ezblock studio version 3.2.143

If I use ezblock OS version 1.2.1 it disconnects from the app as soon as i connect to wifi

If I use ezblock OS version 1.1.4 I get error “cannot import name ‘PiCarX’ from ‘picarx’ (/opt/ezblock/picarx.py)”” when trying to run the example programs.

No other software is installed on the SD card where i installed ezblock os. What can I do to fix this? I need to bring this to the science fair in 4 hours.

You are using EZ Block OS 1.2.1 , go to connect normally.
Then connect to it via SSH, go to /opt/ezblock/ path, find the log log and send us the log information. We are very sorry for the inconvenience.
cd ~/opt/ezblock
cat log