Picrawler servo zeroing gives error

when i enter the script to adjust servos i get the following error can anyone help? thanks in advance

/usr/lib/python3.7/importlib/_bootstrap.py:219: RuntimeWarning: Your system is neon capable but pygame was not built with support for it. The performance of some of your blits could be adversely affected. Consider enabling compile time detection with environment variables like PYGAME_DETECT_AVX2=1 if you are compiling without cross compilation.
return f(*args, **kwds)

i’m using pi 4 with legacy OS. tried part of the suggestions on the robot hat modules for the other posts on here but still doesnt work. formatted SD and started over but now the i2samp bash script isnt working properly either. any suggestons?

1, you executed sudo python3 servo_zeroing.py after the print prompts for the content of the first ignored, you will need to do servo adjustment of the servo, load the rudder plate and upset the angle, and then connected to the robot hat’s P11 pin, to observe the servo is not working it.

2, The i2samp bash script doesn’t work either? Does it not make sound?
Is your robot connected to a screen? If so, please run sudo killall pulseaudio and then run sudo bash i2samp.sh to try.
This assumes you have i2samp installed:
cd ~/picrawler
sudo bash i2samp.sh

thank you! I misunderstood servo zeroing directions but believe they all work fine!

i can run i2samp.sh but sound is cutoff slightly. for example when prompt shows “front right” speaker only says “front ----.” Before i reformatted the speaker worked for the entire test prompt is that something to be concerned about?

It may be related to the network signal, the network is poor, the transfer data will be sluggish and slow.
You run it a few more times to see if the situation occurs every time.