Pidog has no sound or video

I have completed the robot pidog. Downloaded all modules and codes but i have no barking sound from the robot when a code id delivered? I checked all wirings and they seem to be fine. Also i can not connect to the app manually or scan. Says communication error. No video is display as well when a code is sent.

1.Suggest you reinstall i2samp.sh:
cd ~/pidog
sudo bash i2samp.sh
After the installation is successful, restart the Raspberry Pi, and then run the sound example to see the result.
2.If you still can’t get any sound, please execute the command sudo killall pulseaudio, then run the example again to see if the sound can be played normally.
3.About running the video example, but the camera view is not displayed?
Please check if the camera wiring is correct.
Please verify according to the pictures we provided.




Hello i just checked all the wiring for the audio, tried to reinstalled several times the cd ~/pidog sudo bash i2samp.sh. and restarted my pi. I ran a speak example and no sound was still made? You suggested this if i didnt work" f you still can’t get any sound, please execute the command sudo killall pulseaudio”. How do you plug this in as a command it just tells me that it is not a path/ source? I dont know what else to try? I did get my video source to work. Could it be that the speaker is defected? I included a picture of how far i got with the audio but still no sound after?

The image you provided indicates that the installation of the i2samp.sh script was successful.
After rebooting your Raspberry Pi, please try running the sound example again to check if the audio is working properly.
Alternatively, you can verify the speaker functionality by installing mplayer:
sudo apt install mplayer
Run the audio example:
cd ~/pidog/sounds
sudo mplayer woohoo.mp3
If the speakers still do not work, we will send you a replacement robot hat.
Reminder: Make sure the robot hat is powered by the battery.

I will try that. Seems like everything else on the robot works except for the audio. I will let you know how it goes.

Please first test our solution to verify:
Install mplayer:
sudo apt install mplayer
After the successful installation, run the audio example:
cd ~/pidog/sounds
sudo mplayer woohoo.mp3
Check if the speakers are working. If it still doesn’t work, we will send you a new robot hat.
Tip: Remember to connect the battery to power the robot hat.
Also, please provide us with a picture of your robot hat so we can take a look

I will take a picture of it when i get home. I will try and install the mplayer

I took a picture of the top hat



I tried the solution you gave me and still does not work! There is still no sounds coming from the speaker? I installed the player and gives me a file not found



Hello i posted some more pics and tried your solution but i am still not getting any sound?

After successful installation, please enter the correct instructions to run. Please run:
cd ~/pidog/sounds
to switch to the sounds path, then run:
sudo mplayer woohoo.mp3
If it still cannot hear sound, we will send you a robot hat.

I already tried this solution and there is still no sound from the pidog/speaker. I sent pictures above as requested. The mplayer installs but there is still no sound coming from examples. Could you help me, i have tried all i can?

We will send you a robot hat.Please contact us at service@sunfounder.com

Ok i reached out to you. Thank you

Thank you…when i receive the new robot hat will i need to re download all pidog software?

Suggest you reinstall all the library code, and then try running the example code again.