Дисплей Piroman v.2.0 не отображает IP address

Hi. I have Piroman v.2.0 with Home Assistant v.11.1 OS installed on the SSD. Everything works fine, but the display says “DISCONNECT” instead of the LAN IP address.The computer is powered by the original Raspberry Pi 5.1v 3A unit. When Wi-Fi is connected, the IP address is displayed correctly. Please tell me how can I fix the problem?

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting

Add-on: Pironman
Pironman support

Add-on version: 1.0.7
You are running the latest version of this add-on.
System: Home Assistant OS 11.1 (aarch64 / raspberrypi4-64)
Home Assistant Core: 2023.11.1
Home Assistant Supervisor: 2023.11.0

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-timezone: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
[21:57:17] INFO: Configuring timezone (Europe/Moscow)…
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service base-addon-timezone successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
Starting pironman with the following parameters:
temperature_unit: C
fan_temp: 55
display_always_on: false
display_on_for: 180
rgb_on: true
rgb_style: breath
rgb_color: FF00FF
rgb_speed: 20
rgb_freq: 1000
rgb_pin: 10
Warning: Cannot find boot configuration file
set temperature unit to C
set the fan on temperature to 55
set screen_always_on to off
set screen_off_time to 180
set rgb_enable to on
set rgb_switch to on
set rgb_style to breath
set rgb_color to FF00FF
set rgb_blink_speed to 20
set rgb_pwm_freq to 1000
set rgb io to pin 10 (spi)
restarting pironman
stopping pironman
run in foreground
23/11/08 21:57:20,618 [DEBUG] Home Assistant Addon mode

------------------------23/11/08 21:57:20------------------------
pironman version: 2.2.3
config_file: /opt/pironman/config.txt

Kernel Version:
Linux 6fa7f6d2-pironman 6.1.21-v8 #1 SMP Thu Oct 26 14:39:03 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux

PCB info:
Revision : c03115
Model : Raspberry Pi 4 Model B Rev 1.5

23/11/08 21:57:20,666 [DEBUG] power_key_pin : 16
23/11/08 21:57:20,667 [DEBUG] fan_pin : 6
23/11/08 21:57:20,667 [DEBUG] update_frequency : 0.5
23/11/08 21:57:20,668 [DEBUG] temp_unit : C
23/11/08 21:57:20,668 [DEBUG] fan_temp : 55.0
23/11/08 21:57:20,669 [DEBUG] screen_always_on : False
23/11/08 21:57:20,669 [DEBUG] screen_off_time : 180
23/11/08 21:57:20,669 [DEBUG] rgb_enable : True
23/11/08 21:57:20,670 [DEBUG] rgb_switch: True
23/11/08 21:57:20,670 [DEBUG] rgb_style : breath
23/11/08 21:57:20,671 [DEBUG] rgb_color : FF00FF
23/11/08 21:57:20,671 [DEBUG] rgb_blink_speed : 20
23/11/08 21:57:20,672 [DEBUG] rgb_pwm_freq : 1000
23/11/08 21:57:20,672 [DEBUG] rgb_pin : 10
23/11/08 21:57:20,673 [DEBUG]

23/11/08 21:57:20,690 [DEBUG] oled init success
23/11/08 21:57:20,709 [DEBUG] rgb_show
23/11/08 21:57:20,710 [DEBUG] rgb_show: breath
23/11/08 21:57:20,929 [DEBUG] Got IPs: {‘end0’: ‘’}
getCPUuse: could not convert string to float: ‘id.\n’
23/11/08 21:57:21,775 [DEBUG] Got IPs: {‘end0’: ‘’}

The problem, we have fixed successfully.
1、Please click recompile.
2、Or uninstall the pironman software and reinstall it to solve the problem.
Both of the above options are available.

Thank you. Everything worked. This is the best technical support I’ve ever met.

1 Like