Pironman v2 display and home assistant os

I have the Pironman v2 case. When using the regular raspberry pi OS, the OLED display worked correctly.

I have now switched to home assistant OS. I have followed the config instructions and also installed the add-on. In have disabled protection mode. However the display just says “Power off”.

Here are the logs:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service base-addon-banner: starting

Add-on: Pironman
Pironman support

Add-on version: 1.0.7
You are running the latest version of this add-on.
System: Home Assistant OS 10.5 (aarch64 / raspberrypi4-64)
Home Assistant Core: 2023.9.1
Home Assistant Supervisor: 2023.08.3

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

s6-rc: info: service base-addon-banner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service base-addon-timezone: starting
s6-rc: info: service base-addon-log-level: starting
s6-rc: info: service fix-attrs successfully started
[19:49:24] INFO: Configuring timezone (Australia/Sydney)…
s6-rc: info: service base-addon-log-level successfully started
s6-rc: info: service base-addon-timezone successfully started
s6-rc: info: service legacy-cont-init: starting
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
s6-rc: info: service legacy-services successfully started
Starting pironman with the following parameters:
temperature_unit: C
fan_temp: 50
display_always_on: true
display_on_for: 30
rgb_on: true
rgb_style: leap
rgb_color: 0a1aff
rgb_speed: 50
rgb_freq: 1000
rgb_pin: 10
Warning: Cannot find boot configuration file
set temperature unit to C
set the fan on temperature to 50
set screen_always_on to on
set screen_off_time to 30
set rgb_enable to on
set rgb_switch to on
set rgb_style to leap
set rgb_color to 0a1aff
set rgb_blink_speed to 50
set rgb_pwm_freq to 1000
set rgb io to pin 10 (spi)
restarting pironman
stopping pironman
run in foreground
23/09/10 19:49:27,857 [DEBUG] Home Assistant Addon mode
------------------------23/09/10 19:49:27------------------------
pironman version: 2.2.3
config_file: /opt/pironman/config.txt
Kernel Version:
Linux 6fa7f6d2-pironman 6.1.21-v8 #1 SMP PREEMPT Wed Aug 16 19:13:22 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux
PCB info:
Revision : c03115
Model : Raspberry Pi 4 Model B Rev 1.5
23/09/10 19:49:27,908 [DEBUG] power_key_pin : 16
23/09/10 19:49:27,908 [DEBUG] fan_pin : 6
23/09/10 19:49:27,909 [DEBUG] update_frequency : 0.5
23/09/10 19:49:27,910 [DEBUG] temp_unit : C
23/09/10 19:49:27,911 [DEBUG] fan_temp : 50.0
23/09/10 19:49:27,912 [DEBUG] screen_always_on : True
23/09/10 19:49:27,912 [DEBUG] screen_off_time : 30
23/09/10 19:49:27,913 [DEBUG] rgb_enable : True
23/09/10 19:49:27,914 [DEBUG] rgb_switch: True
23/09/10 19:49:27,914 [DEBUG] rgb_style : leap
23/09/10 19:49:27,914 [DEBUG] rgb_color : 0a1aff
23/09/10 19:49:27,915 [DEBUG] rgb_blink_speed : 50
23/09/10 19:49:27,915 [DEBUG] rgb_pwm_freq : 1000
23/09/10 19:49:27,916 [DEBUG] rgb_pin : 10
23/09/10 19:49:27,916 [DEBUG]
23/09/10 19:49:27,936 [DEBUG] oled init success
23/09/10 19:49:27,950 [DEBUG] rgb_show
23/09/10 19:49:27,957 [DEBUG] rgb_show: leap
23/09/10 19:49:28,404 [DEBUG] Got IPs: {‘veth1b2dd5d’: ‘’, ‘veth6da717a’: ‘’, ‘vethb2fab55’: ‘’, ‘veth9845722’: ‘’, ‘wlan0’: ‘’, ‘vethd6bfe4e’: ‘’, ‘veth3d060a3’: ‘’, ‘vethff606f9’: ‘’, ‘veth8d28335’: ‘’, ‘veth1c3228f’: ‘’, ‘vethc0ae50a’: ‘’, ‘veth7a458c7’: ‘’, ‘hassio’: ‘’, ‘docker0’: ‘’, ‘eth0’: ‘’}
23/09/10 19:49:29,472 [DEBUG] Got IPs: {‘veth1b2dd5d’: ‘’, ‘veth6da717a’: ‘’, ‘vethb2fab55’: ‘’, ‘veth9845722’: ‘’, ‘wlan0’: ‘’, ‘vethd6bfe4e’: ‘’, ‘veth3d060a3’: ‘’, ‘vethff606f9’: ‘’, ‘veth8d28335’: ‘’, ‘veth1c3228f’: ‘’, ‘vethc0ae50a’: ‘’, ‘veth7a458c7’: ‘’, ‘hassio’: ‘’, ‘docker0’: ‘’, ‘eth0’: ‘’}
23/09/10 19:49:30,547 [DEBUG] Got IPs: {‘veth1b2dd5d’: ‘’, ‘veth6da717a’: ‘’, ‘vethb2fab55’: ‘’, ‘veth9845722’: ‘’, ‘wlan0’: ‘’, ‘vethd6bfe4e’: ‘’, ‘veth3d060a3’: ‘’, ‘vethff606f9’: ‘’, ‘veth8d28335’: ‘’, ‘veth1c3228f’: ‘’, ‘vethc0ae50a’: ‘’, ‘veth7a458c7’: ‘’, ‘hassio’: ‘’, ‘docker0’: ‘’, ‘eth0’: ‘’}

1、Please provide a video of the problem to us, so that we can analyze and solve the problem.
2、You can try to use two power supplies to power the pironman and raspberry pi separately to see if they work properly.
3、You only connect a power supply to the pironman motherboard, and start the pironman work, and then use a multimeter to measure the output voltage of the GPIO 5V, GND pin, to see how much the voltage, the normal voltage is about 5V. Please provide measurement data or pictures of measurement data.

I tried using a 100w laptop power supply and everything now works correctly.
What is the minimum power supply you would suggest I need?

It is recommended that you use a 5V 3A power supply for power supply, do not use a power supply with much working voltage. It is easy to damage the motherboard.