PiSloth won't connect to WiFi

I have two networks, One named, “Other…”, which gives the error: All English network name are temporarily supported.
The other network is named “CSIS Surveillance Van #21”, which gives the error Wi-Fi connection failed, please try again.
Help! What am I doing wrong?

Is the network you configured your home network and is your cellular device connected to your home network as well. If your cell phone is not connected to your home WiFi, even if you have configured your home network for the cart, it will still fail to connect. This is because your cell phone’s LAN is not the same as the cart’s LAN, resulting in a failure to connect. Your cell phone also needs to connect to your home WiFi, and then the cart is configured with your home network, so that it is the same LAN to connect properly. Or your cell phone open hotspot, then when you configure the network for the cart, enter the network name and password of your cell phone hotspot and configure it, then you can connect normally.

Both networks are WAN’s. The iPhone and iPad are connected the same network as the Raspberry Pi.

I’ve tried to connect with my iPhone and iPad - errors are the same on both devices for both networks.

  1. What system are you currently using? What version?
  2. Do you use Python to control pisloth, or do you use ezblock studio APP to control pisloth?
  3. Suggest you record the operation process into a video and send it to us, so that we can analyze and solve the problem.