Power supply issues with TS-10

I have been using a TS-10 touch screen with a Raspberry Pi 400 for a year, with no issues. In the last few days, the RP400 has been warning about low voltage. It gets its 5V from the TS-10. The RP400 continues to run, but the touch screen function sometimes stops working. At this point, I usually shut down the RP400, and cycle the TS-10 power supply. I cannot think of anything that has changed to cause this issue.

I have a 15V 2A power supply. Will the TS-10 be happy with this, instead of the supplied 12V 1.5A PSU?

Any other suggestions?


1, If you use a 15V 2A power supply, does the low voltage warning appear?

2, You try to use a better typeC cable instead of the Raspberry Pi’s powered USB cable to see if that solves the problem.

Thank you for your quick response.

  1. I have not tried the 15V 2A PSU yet. Can you confirm that the TS-10 is ok with 15V?

  2. I am already using a short (100mm) USB typeC cable from the TS-10 to the RP400, to supply the power.


The 15V 2A PSU is supported. The operating voltage range of the power supply is 7-15V, you should first try to replace the USB TypeC cable to power the Raspberry Pi and see if the low voltage prompt still appears, if so, then replace the 15V 2A PSU to see the result.

I replaced my TypeC USB cable with this one https://www.amazon.co.uk/dp/B0C54HYX9M, and it has solved the problem. It includes a LCD power meter in the connector. The highest value I have seen is 3.9W, which only equates to 0.76A at 5.1V, but the power draw may be spiking faster than the display responds.

I can’t explain why the problem only occurred after a year of use, with no changes to the cabling or software being run on the RP400.

Incidentally, I tried the 15V 2A PSU while I waited for the new USB PD cable. It didn’t solve the problem, but I can confirm that it is compatible with the TS-10.

The power delivery problem appears to be solved.

1 Like