Display The Level: peculiar LED lighting

I have the Euler-Kit, and I set up the “Display The Level” project.

When I run 2.2_display_the_level.py, bars 5 and 10 do not display.

In the shell, I run this command:


And the sixth LED lights instead of the fifth as I would have expected.

If I manually iterate over pins 6 - 15, toggling them on and off myself, I learn that LEDs 5 and 10 do not light at all, and pins 14 and 15 do not seem to toggle anything.

Is this by design? It feels purposeful, as if LEDs 5 and 10 are meant to be turned on through some other mechanism, but I don’t see anything to suggest what is meant to happen here.

  • Trey

This seems to be a simple wrong connection or a little bad contact of the line. Please check the wiring carefully. If there is no mistake in the wiring, try to replace the GPIO10 line. If you have a multimeter or use an LED, check whether the IO10 outputs a high level normally when the level is high.

Okay, cool, I’ll give this another shot.

I redid the project again, and indeed, I must have missed a detail. It worked perfectly.

Heh, my aging eyes… I probably need to get a magnifying glass.

It is never too old to learn, salute you.

1 Like