First computer for my boy ... Pironman board - ghost revision issue?

Hello everyone,

Hoping you can help me. Apologies for the long-text. As you’ll see I am very lost. Appreciate any pointers.

Trying to install the Pironman board up and running: was hoping to give a first computer to my baby boy (he’s too young to understand it yet - but sufficiently enthousiastic about keyboards and screens that he needs a cheaper computer of his own with no moving parts!)

Am running against walls I cannot explain. Have spent days on this and getting nowhere.
Am I doing something wrong or is there an issue with this Pironman PCB I received?

1. Initial attemps (week 1)

Initially attempted to setup with a Pi 4 - 4GB - Rev 1.2. Whatever I tried could not get the leds to initialize. Attempted different Raspian OS versions, all github solutions etc. Incl. manually changing the rpihw.c and recompiling etc. I never got it to work.

Always came down to the same issue - in executing line 131 - RuntimeError: ws2811_init failed with code -3 (Hardware revision is not supported)

The only way I managed to have part of the system work (OLED screen and fan only) was to comment out all “RGB-strip” related lines in the /opt/pironman/

The model I was using should be fine and supported by other members on the forums.

Information on my system:

~$ cat /proc/cpuinfo
Hardware : BCM2711
Revision: 80c03112
Serial: 10000000fa201ca9
Model:  Raspberry Pi 4 Model B Rev 1.2
**~$ uname -a**
Linux testpi 5.15.84-v7l+ #1613 SMP Thu Jan 5 ... armv7l GNU/Linux

Clean Raspbian OS install, into the desktop, update, upgrade and direct into the pironman installation. I use Raspberry Pi power source. (5.1V, 3.0A)

Attempted everything mentioned in this Solution for RuntimeError: "ws2811_init failed with code -3 (Hardware revision is not supported)" | For Raspberry Pi 4 Model B Rev 1.5 and later · Issue #483 · jgarff/rpi_ws281x · GitHub

The only issue I could see was that the Revision in proc/cpuinfo shows 80c03112 whereas in ~$ vcgencmd opt_dump the revision (on line 30) is clearly 00c03122.

Updating the rpihw.c to include 80c03112 does not work as that is not a recognized code.
I attempted to hard-code result = 3 (as that seems to be the output of rpihw.c if run correctly) but also that did not work as certain variables seem to be required elsewhere when compiling.

I’m new to this … so have no idea where to go now.

2. Today

Today I hooked up an older Raspberry Pi 4 Model B Rev 1.1. 1GB RAM.

Implemented with a clean Raspbian OS. Both 32bit and 64 bit. Both worked immediately with just the instructions from the website. This Pi cpuinfo and vcgencmd revisions match each other:

~$ cat /proc/cpuinfo  
Hardware	: BCM2835
Revision	: a03111
Serial		: 10000000e2d85e75
Model		: Raspberry Pi 4 Model B Rev 1.1

Very happy I got this far. However am now stuck on a device with only 1GB RAM … which is not enough to reasonably browse the internet in Chromium.

Question to you: am I missing something obvious? Is it ‘strange’ that my revision numbers don’t match? I am too new to this to understand where to go next. (to get the 4GB Rev 1.2 working)

Thank you very much,


Sorry, we haven’t been able to reproduce this problem, and we are still looking for related solutions.

This turned out to be an issue with my RPi unrelated to the Pironman board or software.

Resolved by tweaking the rpi-ws282x library for my particular board.

1 Like

Have you solved the problem? Please tell us your solution so that we can make programmatic compatibility for this situation.