Pi Camera Rev1.3 in Raphael Kit does not work

Hello, could you please help us out with the following:
Both my boys have Pi4 and we bought Sunfounder Raphael kits with Pi Cameras Rev1.3. In doing projects, we are unable to get the video camera to work.
When both run “libcamera-hello” in the terminal, they get the following even though the cameras are set up for both:

Made X/EGL preview window
[0:15:07.903909527] [2230] INFO Camera camera_manager.cpp:293 libcamera v0.0.0+3866-0c55e522
ERROR: *** no cameras available ***

We are stuck. Any help would be appreciated. Thank you.

  1. It may be that your camera interface is not activated and the error is reported.
    Please follow the link tutorial steps to activate the camera. (After enabling, you need to restart the Raspberry Pi)
    Camera Module — SunFounder Ulimate Raphael Kit for Raspberry Pi documentation
  2. Please check whether the camera is installed correctly?
    Please follow the link to confirm the assembly step directions:
    Camera Module — SunFounder Ulimate Raphael Kit for Raspberry Pi documentation

Thank you for the quick reply! We went through all of your steps and tried the solutions on two machines and both got the same results. Thank you in advance for your very kind assistance. Using a camera should be easy, for some reason, we are having huge trouble.

Using Buster: ran : raspistill -o test.jpg and got:

first error was: Camera control callback cmd=0x4f525245mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

second error: mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
mmal: camera component couldn’t be enabled
mmal: main: Failed to create camera component
mmal: Failed to run camera app. Please check for firmware updates

Using Bullseye: ran photographmodule.py: and got:
File “/usr/local/lib/python3.9/dist-packages/picamera/mmal.py”, line 49, in _lib = ct.CDLL(‘libmmal.so’)
File “/usr/lib/python3.9/ctypes/init.py”, line 374, in init
self._handle = _dlopen(self._name, mode)es/picamera/mmal.py", line 49, in <m OSError: libmmal.so: cannot open shared object file: No such file or directory
Traceback (most recent call last):
File “/home/pi/raphael-kit/python/3.1.1_PhotographModule.py”, line 3, in
from picamera import PiCameraname, mode)
File “/usr/local/lib/python3.9/dist-packages/picamera/init.py”, line 72, in
from picamera.exc import (st):
File “/usr/local/lib/python3.9/dist-packages/picamera/exc.py”, line 41, in import picamera.mmal as mmal
File “/usr/local/lib/python3.9/dist-packages/picamera/mmal.py”, line 49, in
_lib = ct.CDLL(‘libmmal.so’)/dist-packages/picamera/init.py", line 72, i File “/usr/lib/python3.9/ctypes/init.py”, line 374, in init
self._handle = _dlopen(self._name, mode)
OSError: libmmal.so: cannot open shared object file: No such file or directorymo ^CError: libmmal.so: cannot open shared object file: No such file or directory<m

  1. Please confirm whether the interface on the camera module is connected correctly. (picture)
  2. Please confirm whether the FFC cable of the camera is connected firmly. Is the direction of the FFC cable connected correctly? (picture)
    If you confirm that the above steps are correct, the camera module may be damaged.

Thank you. Editing reply, sent too early by accident.

I am have same issue with 32 and 64 bit using Bullseye
Did same checks also have 2 differant cables and camera

1、Please make sure the wiring of your camera is correct. (Follow the steps in the picture above)

2, Please make sure your camera interface is enabled yet:

3、Use the form of taking pictures to test whether the camera is working properly:
raspistiil -v -o /tmp/a.jpg
If the camera works, you can find a.jpg file in /tmp directory.

I no longer have a Camera option in my new pi.
This new 64 bit Pi 4 has no camera option .
The old system had a camera option .
What am I doing wrong?

I have followed Paul’s YouTube video many times. Everything worked great in your kit till I tried the camera. Is you camera compatible with the new 64 bit with bullseye ?

See attached

You execute it with the command: sudo raspi-config
Follow the picture.

I’ve done what you said. 10 times
I have two of your cameras. And two cables.
Still does not see camera .
I used the antistatic band and made sure I had not static. As I said before. I followed all the inininstructions from Topteckboy on youtube . All his lessons and and all your kit stuff worked until I got to lessons 44 45 and tried to use camera. I need a solution. Send it back. New camera. New software. What’s next step.

Sunfounder kit camera now works
With new Pi 4 64bit

You must add an line in /boot/config.txt

I found solution posted on line.

Hope this helps everyone using your kit.

1 Like