PiCar-X Frequent Diconnects


We are still having issues with our cars staying connected to our wireless networks. In some cars, we are able to ssh and drive for about 5 minutes but in others, the cars immediately lose connection. I have tested this over 30 different cars and across three different routers and have been unable to find any rhyme or reason.

This leads me to believe that there is something wrong with the hardware. We use the appropriate 18650 batteries to power the cars but it seems to me that the voltage can randomly drop causing corruption on the sd cards.

Please advise.

Let the user provide a video of the problem to us so that we can easily analyze the problem.
Are you using Python control or ezblock APP control?
Please make sure the network you configured for the cart is stable.

If the SD card doesn’t work or keeps rebooting, please format the SD card and reinstall the system, download and install our source code on the system and try to see.
Or try a new SD card.
Be careful to connect the battery to power robot hat and raspberry pi to keep the battery fully charged.

We have tried completely fresh SD cards with no success.

All of the connections seem to be fine from just looking at them.

Here are some videos to illustrate what is happening. This occurs as soon as the video_car program is running on Python or soon after:

Didn’t quite get what you meant.
Why does the cart in your video rotate in place.
Is the code you are running your own code?
If so, please provide us with your code so that we can help you analyze the problem.
This is not how our video_car.py code works, please watch our video.
cd ~/picar-x/example
sudo python3 video_car.py
Link: Video Car — SunFounder PiCar-X Kit documentation

Okay I have done some intensive testing since my last response.

When I run the video_car.py code that you supply, I can drive around for a few minutes or less before the behavior you see in the video occurs.

I have tried different SD cards, different routers, different Robot Hats, different batteries, and different Raspberry Pis. None of these fixed the issue.

Like I said, it seems that when the behavior occurs you can no longer access the ssh connection. Meaning, as soon as the car starts spinning out you are unable to stop the program by using Ctrl+C and you get a message saying “client_loop: send disconnect: Broken pipe”.

This to me implies that the connection to the car has been broken. As stated above, I have tried the cars on multiple different routers in multiple different conditions and still get the same results.

I am at a loss for what could be happening at this point. Our company enjoys using your product but we can’t continue if this issue persists.

Is there anyway that this could be due to the motors shorting?

Follow up on the above:

It does seem to be a problem with the wiring or electronics on the TT motors. When I swap the motor out for a different one it does not seem to occur or at least happens less frequently.

Would it be possible to have replacement motors sent out? We have quite a few cars exhibiting this problem.

How many motors do you need to replace please? We can replace them for you free of charge.

Sorry for the delay! We have a fleet of about 40 cars with 70 more on the way.

We need 20 motors to replace the ones that have been causing issues and we would be interested in bulk buying more just to have on hand.

Let me know the best course to take!