Picar-X: mediapipe is not supported on this platform... Skip

I am new to Robotics and this is my first Sunfounder robot. I got through the assembly steps for the Picar-X robot but when installing the vilib module, I received the message “mediapipe is not supported on this platform… Skip”. I think I should fix this problem before calibrating the robot so I need some help in this regard. My configuration is:

  • Raspberry Pi 3
  • Raspberry PI OS (Legacy - a port of Debian Bullseye with security updates and desktop environment (released 2023-05-03)
  • Python 3.9.2

I’ve done a little research and I’ve read that mediapipe is not compatible with Python 3.9X but uncertain how to best deal with that information (assuming it is relevant).

Many thanks.

1、please make sure you follow our tutorial steps yet.
2、If an error occurs during the installation process, please try to install a few times to see the results, sometimes due to network anomalies, resulting in the installation of the code when the error occurs.
3、If you install it several times, and the result is the same error, please provide us with a complete screenshot of the error message, so that we can analyze and solve the problem.

Thank you but I took all of those steps before writing this post on the forum. The message comes during the installation of the vilib module (and I have tried installing the module several times with the same message displayed. I think it is caused by mediapipe not being compatible with Python 3.9 which is what is installed with the latest Raspberry Pi OS. Here is the screenshot of the vilib installation process. Attached is the screenshot of the vilib process with the message displayed.

When installing the vilib libraries, the mediapipe prompt appears, it does not affect your normal work, you can ignore it.