Pico Euler Kit Reading Button Value issue?

I am trying to follow the micropython pico Euler 2.5 Reading Button Value tutorial and cannot get the expected result from following the directions exactly. I even made sure to use the same color wires to keep it clear compared to the diagram, then I directly copy pasted the code and hit run and get nothing.

I wondered if the connection to the pico disconnected so I ran a quick test on the onboard LED to make sure it was working and it was.

What am I missing here?

Our engineers are testing it, it takes some time, I’ll get back to you later.

From the pictures you provided, it looks like the wiring is fine.

  1. Please check whether the cable is in good contact with the GPIO breadboard.
    Connect the pico to the right side of the GPIO breadboard, and rewire to see if it can be solved.
  2. Try a new button.
  3. Try replacing with a new 10K resistor.
  4. Try changing the wiring pins and code pins.
    Wiring: originally connected to GP14 pin, changed to GP15 pin.
    Code: Change button = machine.Pin(14, machine.Pin.IN) to
    button = machine.Pin(15, machine.Pin.IN)
    Save and run the program, press a button, and see what’s printing.
  5. If the problem still cannot be solved. Please record the video of the operation steps to us so that we can analyze and solve the problem.

I shifted the pico down the breadboard and moved the wiring and the test went through successfully. Cheers

1 Like