PIronman and POWER OFF

So I’ve just bought a new PIronman case from Amazon, and assembled it. It all seems to work, including the SSD, apart from the WS LED strip and the OLED display, which (at boot) shows the expected temps etc for about 2 seconds, then switches to just display “POWER OFF”. I have powered the box using the connector at the back…

(image removed since I can only put one image per post as a new user)

I have tried multiple cables and multiple sources (including one directly from the wall-socket that provides up to 3A @5V).

I installed the software without any seeming problems:

raspberrypi:~/src/pironman $ sudo python3 install.py
pironman 1.6.2 install process starts:

Kernel Version:
Linux raspberrypi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux

OS Version:
No LSB modules are available.
Description:	Debian GNU/Linux 11 (bullseye)

PCB info::
Revision	: d03115
Model		: Raspberry Pi 4 Model B Rev 1.5

 - update apt... Done
 - update pip3... Done
Install dependencies with apt-get
 - apt --fix-broken... Done
 - install net-tools... Done
 - install python3-smbus... Done
 - install i2c-tools... Done
 - install libtiff5-dev... Done
 - install libopenjp2-7-dev... Done
 - install zlib1g-dev... Done
 - install libfreetype6-dev... Done
 - install libpng-dev... Done
 - install libxcb1-dev... Done
 - install build-essential... Done
 - install python3-rpi.gpio... Done
 - install python3-dev... Done
Install dependencies with pip3
 - install rpi-ws281x... Done
 - install pillow --no-cache-dir... Done
Config gpio
 - enable i2c ... Done
 - enable i2c in config... Done
 - disable audio... Done
 - config gpio-poweroff... Done
 - config gpio-ir... Done
create WorkingDirectory
 - create dir... Done
 - copy service file... Done
 - add excutable mode for service file... Done
 - copy bin file... Done
 - add excutable mode for bin file... Done
create config file
 - copy config file... Done
check startup files
 - enable the service to auto-start at boot... Done
 - run the service... Done
Whether to restart for the changes to take effect(Y/N):

I’ve checked that the jumper cap in step 3 is where it was supposed to be (although mine was already set correctly)…

… and I checked that the entry was made at the end of /boot/config.txt…


It’s really frustrating because I can see it working every time I change the settings with ‘pironman’ and then it resets back to “POWER OFF” again. If I run…

raspberrypi:~ $ sudo python3 /opt/pironman/main.py

------------------------23/09/08 12:20:45------------------------
pironman version: 1.6.2
username: simon
config_file: /home/simon/.config/pironman/config.txt

Kernel Version:
Linux raspberrypi 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr  3 17:24:16 BST 2023 aarch64 GNU/Linux

OS Version:
No LSB modules are available.
Description:	Debian GNU/Linux 11 (bullseye)

PCB info:
Revision	: d03115
Model		: Raspberry Pi 4 Model B Rev 1.5

23/09/08 12:20:45,597 [DEBUG] power_key_pin : 16
23/09/08 12:20:45,597 [DEBUG] fan_pin : 6
23/09/08 12:20:45,597 [DEBUG] rgb_pin : 12
23/09/08 12:20:45,597 [DEBUG] update_frequency : 0.5
23/09/08 12:20:45,597 [DEBUG] temp_unit : C
23/09/08 12:20:45,597 [DEBUG] fan_temp : 50.0
23/09/08 12:20:45,598 [DEBUG] screen_always_on : True
23/09/08 12:20:45,598 [DEBUG] screen_off_time : 60
23/09/08 12:20:45,598 [DEBUG] rgb_switch: True
23/09/08 12:20:45,598 [DEBUG] rgb_blink_speed : 50
23/09/08 12:20:45,598 [DEBUG] rgb_pwm_freq : 1000
23/09/08 12:20:45,598 [DEBUG] rgb_color : 0a1aff
23/09/08 12:20:45,598 [DEBUG] 

23/09/08 12:20:45,647 [DEBUG] rgb_show
23/09/08 12:20:45,650 [DEBUG] rgb_show: breath

… the same thing happens (POWER OFF after 2 secs or so) and the script hangs until I press CTRL-C.

Any ideas ? :slight_smile:

Here’s the image I had to remove:

I’m sorry to reply you so late, we are on vacation on Saturday and Sunday.

1、You can try to use two power supplies to power the pironman and raspberry pi separately to see if they work properly.
2、You only connect a power supply to the pironman motherboard, and start the pironman work, and then use a multimeter to measure the output voltage of GPIO’s 5V, GND pin, see how much the voltage is, the normal voltage is about 5V. Please provide measurement data or pictures of measurement data.

So attaching two power supplies to the PI, I get:

[one image per post, so new post]

And if I only have the PIronman supply connected, I get:

Both of those would seem to be ok :slight_smile:

From the data you provided, it is normal.
Do you mean that the pironman will reboot itself after a certain period of time?
And it shows “power off”, will it happen if you connect two power sources.
The functions of the pironman work fine, right?
Suggest you provide us with a video of the problem so that we can analyze and solve the problem.

So here’s a video of me powering on the device, it booting, it showing the LCD stats for about 2 secs, and then it switching into “POWER OFF” (and staying there).

[sigh, apparently “new users cannot upload attachments”, which isn’t particularly useful]. I will try and find a place to host the video. In the mean-time, see if this link works…


I have exactly the same problem. The board seems to be working, as the NVMe works, and the SDCard. But the light strip isn’t working, and the OLED display shows the correct display for about 1-2 secs, then it shows Power Off.
Weird, because I came exactly to this forum to solve this problem as my connections all seem to be OK.

I’ve sent a couple of videos. Hopefully that’ll help work things out.

Not sure if it’s worth mentioning, but mine seems to be a ‘v1’ pironman, at least the printed docs take me to pironman.rtfd.io

Also a V1 here and also bought from Amazon.

@SpacedCowboy, found the solution:
Power it from the backside!!!

I’m already doing that, still got the problem :frowning: