Pironman Case Not Booting from Daughterboard

Hello everyone,

I’m currently experiencing an issue with my Pironman case and I’m hoping someone here might be able to help.

The problem is that the case will not boot up when powered from the daughterboard’s USB-C port. However, when I power it up directly from the Raspberry Pi board’s USB-C port, it boots up just fine. When powered this way, the OLED display and lights don’t function correctly, which leads me to believe the issue lies with the daughterboard.

I’ve done some troubleshooting already. I’ve tested the SD card and power supply with another Raspberry Pi that I have in an Argon One case, and everything works perfectly in that setup. This leads me to believe that the issue is not with the power supply or the SD card.

I’ve also checked all the connections between the daughterboard and the Raspberry Pi, and everything seems to be in order. I’m suspecting a potential issue with the daughterboard itself, but I’m not entirely sure.

Has anyone else experienced a similar issue? Any suggestions on what could be causing this and how to fix it would be greatly appreciated.

Thank you in advance for your help.

1, Are all the short connectors of the motherboard connected properly?
2, GPIO FFC is connected correctly and solidly, is the direction correct. (As shown in the figure)
It is recommended that you re-plug the GPIO FFC to try, or replace the GPIO FFC cable with a new one.

Thank you for your response and your suggestions. I appreciate your attention to my issue.

I want to clarify that I have already undertaken several troubleshooting steps in line with the recommendations from Susan from your support team via email.

  1. Connections: I have meticulously checked all short connectors on the motherboard, ensuring they are properly connected.

  2. GPIO FFC: I have verified the GPIO FFC connection. It is solidly connected, and its direction is correct per your guide. As recommended, I’ve also re-plugged the GPIO FFC, but the problem persisted.

  3. GPIO FFC Replacement: I’ve replaced the original GPIO FFC cable with a new one, and yet, the issue remains.

Beyond these measures, I have also performed several other tests:

  1. SD Card and Power Supply: I’ve tested the SD card and power supply with another Raspberry Pi in an Argon One case. They both work perfectly in that setup, which indicates that these components are not the cause of the issue.

  2. Different Raspberry Pi board: I’ve even disassembled my ArgonOne case to test another Raspberry Pi board with the Pironman case. However, the system still would not power on from the daughterboard.

With all these tests, I am led to believe that the problem lies specifically with the daughterboard. It does not power the system on as intended, while the system boots up just fine when powered directly from the Raspberry Pi board’s USB-C port.

Given these findings, I am convinced that the issue lies with the daughterboard. I believe a replacement for this component might be the most effective solution at this point.

I look forward to hearing your thoughts on this.

Best regards,

Gary Kokaisel

What is the specification of the power USB cable you are currently using?
Do you have a spare power USB cable that you can replace and see the results?
We recommend you to use the official 5V 3A power supply USB cable of Raspberry Pi.
If the power supply problem is ruled out, the motherboard may be damaged, we will arrange to send you a new motherboard.
Sorry for the inconvenience, please check again. Thank you for your patience!

ADDED: Because we went ahead and did a reproduction test of everything as you pointed out.
When powering the pironman with a poorer power supply, the raspberry pi won’t boot up at all.
When powering the raspberry pi directly from the power supply, it worked again.

Thank you for your continued correspondence. I want to emphasize that I am using the official 5V 3A power supply that’s recommended for the Raspberry Pi. This is a reliable and approved power supply, and I have two of these which I’ve used interchangeably with my two other Raspberry Pi systems in different cases. Both have performed without any issues in those setups.

I have also tried an alternative USB-C cable as requested, which is known to work with other devices, yet the problem with the Pironman case persists.

Given these tests, I am confident that the power supply and USB-C cable are not at fault. Furthermore, since I’ve tested the Pironman case with two different Raspberry Pi boards and experienced the same issue, this continues to lead me to believe that the issue lies specifically with the Pironman daughterboard.

I appreciate your offer to send a new motherboard, as it aligns with my suspicion that the daughterboard is the cause of the issue. I’m eager to resolve this situation and get my Raspberry Pi system up and running with the Pironman case.

Product this situation is need to send you a new motherboard, please continue to communicate with Susan in the after-sales department, she will send you a new motherboard.