Rgb_strip and mu_sh3001 do not initialise

Raspberry 4
Original Power-Supply from the Pi-Shop

Occurance: always
The error occurs with fully loaded battery and also when the hat is connected to current.
The error occurs with ssh and also when directly connected via hdmi and keyboard.

Starting yesterday my Pidog does not initialise (correctly)
imu_sh3001 and rgb_strip

  1. On 08_pushup the LEDs illuminate correctly, but the Pi brings error messages.

  2. When you run a script, e.g. 03_patrol, it stops when it wants to call the rgb-strip

  3. On the function demo I ran through all commands.
    The output of the pidog was always as expected,
    but action 24 brings an error message.

  4. 11_keyboard control works mainly correctly,
    but on key “minuscular L” an error message is shown and the script terminates.

  5. When I ran the test scripts, there were NO error messags
    and the output of the pidog was always as expected,

  6. I re-installed all modules, but it makes no difference.

03 LED working but errors

04 Tests

05 keyboard control

How can I fix it, since the tests are running OK, and as said, for some days it worked correctly.

1.When you ran the example script, you encountered errors with imu_sh3001 and rgb_strip.
This could be due to incorrect or loose wiring between the 6-DOF IMU module and the 11-channel light board.
Please check the wiring to ensure it is correct and secure.
If possible, provide us with a picture of the wiring for further assistance.
You can also refer to our online tutorial, which includes a video on the assembly process, specifically the wiring section. https://youtu.be/Gskge1fDR30

2.You encountered an error message: “ERROR: [Errno 121] Remote I/O error.”
This could indicate that the i2c is not enabled.
To check if the i2c signal address is recognized, please execute the command “i2cdetect -y 1” and provide us with a screenshot of the output.
If the i2c is not enabled, you can enable it by using the command “sudo raspi-config” and navigating to the settings page. [as photos]

3.Please ensure that the battery has sufficient charge, as the battery needs to be connected to the robot hat for it to work during startup.

4.To test if the sound is working, you can run the sound example and check if it produces sound. You can also try reinstalling the i2samp.sh by following these steps:
cd ~/pidog
sudo bash i2samp.sh
After successful installation, restart the Raspberry Pi and try running the example code again to see if it works properly.

I ran a number of tests, sometimes with issues, sometimes without
and I think I finally found the culprit.

The indicator for OK or NOK is the light of the 6-DOF-IMU - when it is off your problems just started.

When you move the head around (that of the dog of course),
it seems that sometimes the cable of one of the white connectors to the front comes lose, just very slightly. It is hardly to see, but seems to be enough to create sometimes problems.

So the issue seems to be solved.

Do you mean the I2C interface cable connecting the robot hat is loose? And was affected by the head movement during operation?
In theory, the wiring and connections for the I2C interface should not be impacted by the head movement.
Could you please share some photos or a diagram of how you have the cable connected?

No, the cable came probably lose after head action and toppeling over.
When you run the example scripts, like the covershot and then continue with something with big leg movements, it just falls over to the side, while the legs are still moving and pushing it over the carpet. I pressed the plug now seriously in and it seems to hold.

One problem left is the distance sensor. It delivers false readings.
As a result, with 3_patrol.py it just stops at one stage.

The readings change between -1.0, correct distance and 29465178537984.0 back and forth, although nothing has moved. Then at one stage it seems to lose the connection to the WiFi, because ctrl + c does not exit the script, but resets the connection.

Dist 03

Please let us know what version of the system you are currently using.
What model of Raspberry Pi are you using?
This will help us to reproduce the problem and find a solution.