Servos not responding to P11

I have a crawler kit that i am building with my grandson. We are attempting to zero the servos but they are not responding to either the or to the ezblock image , we have tried it both ways. The P11 port has power. We have tried at least half a dozen servos in the kit and none of them move at all when plugged in.

There’re two ways:

The first method:

You need to execute the python script command to return to zero.

To install the Raspberry Pi operating system;

Download the source code to install the library;

Adjust the servo back to zero;

Please follow the tutorial steps.

If you have further questions, please provide error screenshots or videos.

The second method:

  1. First, install EzBlock OS (3.1) on the Micro SD card. After the installation is done, insert it into the Raspberry Pi.

  1. To ensure the servo has been correctly set to 0°, you have to insert the rocker arm into the servo shaft, and then insert the rocker arm gently and rotate to different angles.

  2. Follow the instructions, insert the battery holder cable and turn on the power switch. After 1-2 minutes, there will be a sound indicating that the Raspberry Pi has started successfully.

  3. Now you will see the servo arm rotate to a specific position (0°). If the servo arm does not return to 0°, press the RST button to restart the Robot HAT.

  4. You can continue the installation. It’s very clear in our tutorial.

Note: The ezblock OS image must be installed and burned into the SD card, then insert the SD card into the car, and lastly start the car.

Tips: Method 1 and Method 2 have different mirroring systems, and these two cannot share the same SD card. If you find that the servo does not move when you are adjusting the servo to zero, it is possible that it is already in the 0° position, therefore no action. So before you adjust the servo, install the servo rocker arm, twist the rocker arm to disturb the angular position, and then connect to the P11 interface for zero adjustment.

Hi. I have been through these instructions a number of times with no good result. Here is a link to a video of the pi booting, chiming, me plugging in a servo, and the servo not moving.

  1. Firstly, start the robot and wait for it to turn on. If you hear a loud sound, it means that the robot has been successfully turned on.
  2. Connect the disturbed servo angle to the p11 pin
  3. Press and hold the USR button again and don’t let go, then press the RST button to return to zero, and you can wait for the servo to return to zero. (Tips: Before the servo returns to zero, press and hold the USR button and do not let go)

Thank you for this. I followed your video carefully and got no result. Here is a video. I am going to assume this is DOA and am returning it.

Here’re two videos for your reference!
After you try to connect the car with the app, create a new project, go to the block editing page, find the module for setting the servo angle, and then select pin p11 to 0 angles, and click Run.
(It is not necessary to select the p11 pin, other pins can also be selected, just plug the corresponding pin)

Connect the disturbed angle of the steering gear to p11, and observe the status of the steering gear.

If you are connecting for the first time, you need to configure the network. Here’s the instruction.

If all 12 servos still do not respond, the robot that may be broken.
Please provide your detailed address, we will send you the robot hat.
It should be fixed.