Extra delay to shutdown\reboot

Does anyone have this “problem” of delay when you shutdown or reboot your Pironman 5 booting from nvme SSD Patriot P310 240Go , rasbian 64 bits recommended installation. All updates are done! POWER_OFF_ON_HALT=1

Can you please record a video of this process for us? It would be helpful for us to analyze and solve the problem.
We have also conducted tests and did not encounter any noticeable latency issues.
If you want to boot pironman5 from an SSD, you will need to configure the file.
Please refer to our online tutorial:
1.Enable PCIe and configure the config.txt file according to the tutorial steps.
2.Install the system on the SSD.
3.Configure the boot from SSD. (Important)

I’ve follow the config step by step. there is videos of my problem, 1 for reboot, 1 for shutdown. Hope this will help you to help me :slight_smile: sunfounder

Your situation should be normal.
The command “sudo shutdown now” will immediately send a shutdown signal, but it needs to wait for the running programs to exit safely. The time it takes for the programs to exit depends on the complexity of the program and the tasks it is processing, so it may vary.
The command “sudo reboot” will also first send a shutdown signal to the running programs, wait for them to exit normally, and then restart the system. The restart time also depends on the speed of the program exit.
In both cases, the running programs need a certain amount of time to complete their current tasks and exit safely. But the specific shutdown time may vary because:
The complexity of the programs and the current tasks they are processing may be different.
The other operations that the system needs to perform during shutdown and restart may also affect the shutdown time.

I made many tests and I can confirm, this delay isn’t normal. 1- new fresh installation on SD card rasbian full 64, made all updates, install pironman 5, step by step : no delay on each reboot. 2- copy this SD card to my nvme SSD as instructions, change boot order, shut down, remove SD card from case and restart, everything seems ok, I reboot, always delay. Turn off RPI, insert SD card, start it, reboot it, no delay.

I notice something, when SD card is insert, the led beside is green and flash only when activity. But when there’s no SD card, the led is off. So I think there’s a software problem who want to communicate with SD card or maybe hardware problem with SD card expansion.

And in the instructions for enable PCIe, isn’t clear btparam=pcie1x or btparam=nvme or both like pic?

Without inserting an SD card and booting from the SSD, there will be a delay.
This indicates that the boot order for your Raspberry Pi has not been successfully changed, and it is still booting from the SD card. Even if you remove the SD card, it will still try to detect the SD card first before detecting the SSD, causing the longer boot time.
The screenshot you provided only shows enabling PCIe, but does not show the configuration to change the boot order.
If you want to boot from the NVMe SSD, you’ll need to configure it further, like this:
sudo rpi-eeprom-config --edit
Please refer to the tutorial link for more details:

I have change the boot order like mentioned in instruction. I made it a lot of times. I notice when the Pi is ON with SD card insert, the led of RPI board is green but if I power up the Pi without SD card, the led is OFF. And turn red when the Pi is shutdown. Boot order is well set, I also create SD card bootloader for nvme. PCIe is set on boot\firmware\config.txt. no overclocking everything is stock.

I’ve try all kind of installations, copying OS from SD card to nvme, imager directly on nvme, removed SD card, putting SD with bootloader nvme, …

The only thing I notice is the LED of RPI.

I’m using Raspberry pi OS 64 bit bookworm full with desktop Linux 6.6.31-rpt-rpi-2712 aarch64

I’ve add 2 more videos on my OneDrive with link “Sunfounder” up there, one with SD card insert and one without SD card “half insert”. I made another test to leave a completed formated SD card in TF reader.

When the Pi is in the ON state with an SD card inserted, the RPI board’s LED will be green. However, if I start the Pi without an SD card, the LED will turn off. This is a normal phenomenon, as it is an indicator for the Raspberry Pi to recognize the SD card status.
Regarding the delay issue, it is not directly related to the SD expansion board.
You can try removing the SD expansion board and then restarting or shutting down the device. I also recommend that you visit the official Raspberry Pi forum to seek further assistance.

Oh well, at least when I’ll get some times, I’ll disassemble it, keeping the essentiel, rpi5, HDMI board and nvme hat and try to isolate the issue.

Any further help,please feel free to contact.

I’ve made test, remove MicroSD extender, insert MicroSD directly into rpi5 boot it and then reboot, no delay. Remove MicroSD, only run with nvme, reboot it, no delay. Install MicroSD extender without MicroSD, boot and reboot, there’s delay. Install MicroSD into MicroSD extender, boot and reboot, no delay. In conclusion, there is a problem with MicroSD extender when there’s no MicroSD card inserted. You can find extra videos into the link up there and there’s some pics of each test

Please contact us at service@sunfounder.com

I received a new SD card extension, same issue. Bad conception? Is there any contact inside the slot to informe that there’s a SD card plugged?