Pironman - not recognizing SSD

Is it possible to increase the USB power provided to the SSD?

When I connect the pironman board to my Pi (Pi 4, 1GB, Rev 1.1) the pi cannot detect the SSD drive. More precisely - it temporarily seems to detect it but then lets it go when it draws too much power. Continuous notifications of ‘Drive was removed without ejecting’.

  1. It does not show up using
    sudo fdisk -l or the GPARTED tool or lsblk

  2. dmesg seems to show that it is triggering an overcurrent change

.011489] sd 0:0:0:0: tag#25 uas_zap_pending 0 uas-tag 1 inflight: CMD
[ 559.011507] sd 0:0:0:0: tag#25 CDB: opcode=0x0 00 00 00 00 00 00
[ 559.011621] sd 0:0:0:0: [sda] Read Capacity(16) failed: Result: hostbyte=0x07 driverbyte=DRIVER_OK
[ 559.011631] sd 0:0:0:0: [sda] Sense not available.
[ 559.011659] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x07 driverbyte=DRIVER_OK
[ 559.011666] sd 0:0:0:0: [sda] Sense not available.
[ 559.011692] sd 0:0:0:0: [sda] 0 512-byte logical blocks: (0 B/0 B)
[ 559.011699] sd 0:0:0:0: [sda] 0-byte physical blocks
[ 559.011718] sd 0:0:0:0: [sda] Write Protect is off
[ 559.011726] sd 0:0:0:0: [sda] Mode Sense: 00 00 00 00
[ 559.011740] sd 0:0:0:0: [sda] Asking for cache data failed
[ 559.011746] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 559.012702] sd 0:0:0:0: [sda] Read Capacity(16) failed: Result: hostbyte=0x07 driverbyte=DRIVER_OK
[ 559.012722] sd 0:0:0:0: [sda] Sense not available.
[ 559.012751] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x07 driverbyte=DRIVER_OK
[ 559.012757] sd 0:0:0:0: [sda] Sense not available.
[ 559.012816] sd 0:0:0:0: [sda] Attached SCSI disk
[ 559.203164] usb usb2-port3: over-current change #363
[ 559.419303] usb usb2-port4: over-current change #343
[ 559.635229] usb usb2-port1: over-current change #369

  1. However the lsusb does not show a current draw.
    (max 150mA for the mouse and keyboard).

Is there a way to increase the current made available to the SSD drive? Raspberry Pi documentation claims up to 1.2A should be available.

Particularly since the 5V is delivered directly to the Pironman Board I do not see how this is possible.

Any help would be highly appreciated.

Thank you


  1. Try to comment out the 3d driver in /boot/config,
    #Enable DRM VC4 V3D driver
    #max_framebuffers=2, this will reduce the current required by the Raspberry Pi to start
  2. The SSD on the sub-board is directly powered by the USB port of the Raspberry Pi. You can try to supply power directly from the power port of the Raspberry Pi to see if it can drive the SSD.

Have tried this. It makes no difference. Same error messages.

  1. What are the voltage and current parameters of the power supply you use? The official power supply of Raspberry Pi 4 is 5v, 3A
  2. Do you have the parameters of SSD-rated current, maybe your SSD requires a larger current
  3. If you have connected other devices via USB, please unplug it and leave the SSD for another try.
  1. I use the official Raspberry Pi power supplies. So 5.1V, 3.0A. This was inserted both into the board and a separate one into the Raspberry Pi itself. (Also a 5.1V, 3.0A). So there should be enough current available for whatever the SSD needs.
  2. I am not able to find a spec sheet online. I guess that is a bad sign. Amazon recommended it as being frequently purchased with Pi Argon case.

Intenso M.2 SSD - Sata III - Top. 256 GB

(Attachment solid_state_drive_internal_m.2_top.pdf is missing)

Assuming that there is no problem with the SSD and the power supply, please use a typec data cable instead of the SSD bridge board to connect the Raspberry Pi USB and the SSD interface of the expansion board to see if it works. If yes, then the bridge board is damaged, and we will reissue the damaged device for you.