Pironman Raspberry Pi 4 Case v2 (GPIO using 12 not 10)not seeing SSD

I tried using a 5v 3.5amp and now a 5v 4amp adaptor on the pironman board and it seems it sees the ssd for a sec then doesn’t. I tried using one adaptor on the pi and one on the pironman board and same difference. I also tried with wifi/bt turned off and using only rj45 connection, no usb keboard or mice either.

NVM SSD WD Green (pi gui copy program saw it once as Samsung MZNTY128HDHF-000 But fails to copy. Its specs says 5w and 110mW so not sure why the usb3 port @ 1amp can’t power it.
from amazon: Western Digital 1TB WD Green SN350 NVMe Internal SSD Solid State Drive - Gen3 PCIe, QLC, M.2 2280, Up to 3,200 MB/s - WDS100T3G0C

84.699994] usb usb2-port1: over-current change #1
[ 84.798029] usb 1-1-port1: over-current change #1
[ 84.915851] usb usb2-port2: over-current change #1
[ 85.017873] usb 1-1-port2: over-current change #1
[ 85.131759] usb 2-2: USB disconnect, device number 2
[ 85.355920] usb usb2-port3: over-current change #1
[ 85.459768] usb 1-1.2: new high-speed USB device number 3 using xhci_hcd
[ 85.571904] usb usb2-port4: over-current change #1
[ 85.787963] usb usb2-port1: over-current change #2
[ 86.149555] usb 1-1-port3: over-current change #1
[ 86.284121] usb 2-2: new SuperSpeed USB device number 3 using xhci_hcd
[ 86.305325] usb 2-2: New USB device found, idVendor=152d, idProduct=0580, bcdDevice= 1.00
[ 86.305345] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 86.305350] usb 2-2: Product: USB Mass Storage
[ 86.305353] usb 2-2: Manufacturer: JMicron
[ 86.305357] usb 2-2: SerialNumber: 152D00580000
[ 86.311890] usb-storage 2-2:1.0: USB Mass Storage device detected
[ 86.312184] usb-storage 2-2:1.0: Quirks match for vid 152d pid 0580: 800000
[ 86.312317] scsi host0: usb-storage 2-2:1.0
[ 86.371391] usb 1-1-port4: over-current change #1
[ 87.328345] scsi 0:0:0:0: Direct-Access JMICRON JMS580 PQ: 0 ANSI: 6
[ 87.329465] sd 0:0:0:0: Attached scsi generic sg0 type 0
[ 87.332654] sd 0:0:0:0: [sda] Unit Not Ready
[ 87.332674] sd 0:0:0:0: [sda] Sense Key : 0x5 [current]
[ 87.332678] sd 0:0:0:0: [sda] ASC=0x20 ASCQ=0x0
[ 87.335668] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x00 driverbyte=DRIVER_OK
[ 87.335686] sd 0:0:0:0: [sda] Sense Key : 0x5 [current]
[ 87.335690] sd 0:0:0:0: [sda] ASC=0x20 ASCQ=0x0
[ 87.337811] sd 0:0:0:0: [sda] 0 512-byte logical blocks: (0 B/0 B)
[ 87.337826] sd 0:0:0:0: [sda] 0-byte physical blocks
[ 87.339474] sd 0:0:0:0: [sda] Write Protect is off
[ 87.339494] sd 0:0:0:0: [sda] Mode Sense: 00 00 00 00
[ 87.340132] sd 0:0:0:0: [sda] Asking for cache data failed
[ 87.340147] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 87.340928] sd 0:0:0:0: [sda] Attached SCSI disk
[ 142.468329] sd 0:0:0:0: [sda] Unit Not Ready
[ 142.468362] sd 0:0:0:0: [sda] Sense Key : 0x5 [current]
[ 142.468371] sd 0:0:0:0: [sda] ASC=0x20 ASCQ=0x0
[ 142.472594] sd 0:0:0:0: [sda] Read Capacity(10) failed: Result: hostbyte=0x00 driverbyte=DRIVER_OK
[ 142.472618] sd 0:0:0:0: [sda] Sense Key : 0x5 [current]
[ 142.472625] sd 0:0:0:0: [sda] ASC=0x20 ASCQ=0x0

sudo lsusb -t
/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M
|__ Port 2: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 5000M
/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M
|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M

Linux piman 6.6.22-v8+ #1746 SMP PREEMPT Wed Mar 20 17:19:49 GMT 2024 aarch64 GNU/Linux

Please Help.

I saw this in another post and tried it as well. Still no SSD

  1. Try to comment out the 3d driver in /boot/config,
    #Enable DRM VC4 V3D driver
    #max_framebuffers=2, this will reduce the current required by the Raspberry Pi to start
  2. The SSD on the sub-board is directly powered by the USB port of the Raspberry Pi. You can try to supply power directly from the power port of the Raspberry Pi to see if it can drive the SSD.

I am very sorry, you are currently using NVMe SSD?
The M.2 SSD hard disk interface only supports SATA protocol, not NVME/PCIe oh.
Please see our tutorial for tips:

Ok I am kinda new to nvm etc… But the ssd i have matched the connector on pironman board. I also saw a reveiwer using this same drive in his v1 pironman case review.

I also bought another pironman case 2 for parts and now i dont get any over current error mesg but still doesn’t work. I will get a ssd storage device now

Can you recommend a model# of a 1tb i can get that will work please.

Now i have a pironman board not seeing ssd. I Tried Pi by itself and it works so it seems the main board is bad. How do i get a replacement. I have purchased two cases so the other one does work. Shawn

  1. You can go to Amazon and search for “1 tb m.2 sata ssd” keyword, can filter out the correct SSDs
    Amazon.com : 1 tb m.2 sata ssd
  2. M.2 SSD hard disk interface only supports SATA protocol, does not support NVME/PCIe oh.
    If you are using a SATA SSD, it still cannot be recognized.
    Please use the following steps to troubleshoot the problem, let us know the result, and preferably provide us with photos or other information so that we can locate the problem.

a. Use a typeC cable instead of a USB bridge board to see if the SSD can be recognized normally.

b. Use the typeC cable instead of the USB bridge board, replace the other USB ports on the Raspberry Pi to see if the SSD can be recognized normally.

c. Use typeC cable instead of USB bridge board, pironman motherboard and computer USB connection, see if the computer PC can recognize SSD.

I was able to put SSD into pironman board then use USBC cable to PC. Computer saw SSD and I flashed is to it.