SOLUTION: Raspberry Pi 4B unit not working

The installation program showed that the directory " ‘user/bin/local/arduino’ did not exist". So I created the subdirectory manually using Terminal. Reinstalled and everything works great! NOTE: I have TWO power supplies: The 3A on the Pi and a 4A on the daughter board (the one that Pironman provided).

Please use our compatible system to install the Pironman software. Follow the steps outlined in our Pironman V2 tutorial.
If you encounter any errors during the Pironman software installation process, please provide a screenshot of the error so we can analyze and help resolve the problem.
If possible, you can also provide a video of the issue, which would help us analyze and assist in solving the problem.
You can upload the recorded video to OneDrive, share the video link with us, and grant us access to view it.

NOTE: If the blue ring around the button on the front of the machine is NOT on, press it and the LED display will turn on. Hold long press to turn unit off.

This is normal. When directly powering the Raspberry Pi with Pironman, the front button is the power switch button, and the blue light ring is the power indicator light. It’s important to note that it’s not recommended to power the Raspberry Pi and Pironman simultaneously, as this will prevent Pironman from being able to control the Raspberry Pi’s power on/off. In this case, the button will essentially be non-functional, and you only need to power Pironman, which will then power the Raspberry Pi.

Also, please ensure that the blue light is illuminated when using the device.

As for the issue you mentioned previously about ‘/user/bin/local/arduino’ not existing, could you please provide more context about the command you were running when you encountered that error? Our installation instructions don’t seem to be related to Arduino.

I have the Arduino Individual Development Environment (IDE) installed on my machine. Don’t know why the installation program for pironman 4 needed to have that subdirectory manually installed. Creating that subdirectory prevented an error message from displaying on a re-installation. I think this is a moot issue, not worth following. Thank you.